诸多python工具包都需要这个库

图片 5

sklearn是scikit-learn的简单称谓,好多python工具包都要求那几个库

设置顺序:

  wheel

  numpy

  scipy

  sklearn

因为那么些库一向安装不佳,都不曾引力持续攻读机器学习了,,,,kuku

报错原因:

  Windows系统的pip
install恐怕对于scipy等库的装置相当的小支持,因而要求手动安装

设置进程:

#由于本身的计算机python2和python3同在,而小编要安在python3方面,因而上面全体的都有个3

先 pip3
install wheel

在cmd分界面输入python3

   #实际那时已经出来版本信息了,只需掌握是3.X本子和win32照旧64就能够

   
 >>> import pip

   
 >>>
print(pip.pep425tags.get_supported(卡塔尔(英语:State of Qatar)卡塔尔国展现当前版本音讯

   
 #我的是36,36,32

进入
www.lfd.uci.edu/%7Egohlke/pythonlibs/ 那一个python库下载分界面

找到numpy+mkl和scipy下载相应版本

   
 就算Computer中已经安装过numpy,但如故要再一次下载(首要是mkl)

下载完成后,步向有whl文件的分界面,在ftp地址栏输入cmd

 再输入
pip3 install +whl文件的姓名,安装whl。

   
 先安装numpy,再安装scipy

图片 1

图片 2

双重步向python3,scipy引用成功

图片 3

sklearn安装相对简便易行,直接pip3 install
sklearn就可以

图片 4

图片 5

安装成功,可以使用!